Give us your feedback!

Please let us know how we can serve you better.  Just leave a comment below. All suggestions are gratefully accepted.
 
 

8 replies
    • Rich Stillman
      Rich Stillman says:

      Hi Darryn,

      Thanks for asking. We are not charging at the present time to submit a listing. We’ve added this to the FAQ’s on the support page.

      Reply
  1. terry.vasquez@regus.com
    terry.vasquez@regus.com says:

    I am experiencing issues with attaching/uploading images. About 75% of the images I am trying to upload are unresponsive and I have to go back and edit the record again to get the image to attach. I have tried multiple times with varying numbers of attachments (from 1 to 5).

    Reply
    • Rich Stillman
      Rich Stillman says:

      Hi Terry,

      Thanks for writing us. There is a size limit on the pictures of 4MB. And also a pixel limit on height and width of those images. The reason for this is so that the site doesn’t get slowed down trying to load big images. Are the images you’re trying to upload large sizes? If so, it’d be great if you could save them to a smaller size.

      If that isn’t the source of the problem, for sure write us back. We haven’t had issues with uploading images as yet, so we want to make sure we solve your issue.

      Reply
  2. Barbara J Ingram
    Barbara J Ingram says:

    I am unable to connect with listings due to “reCaptura” issues. It happens despite leaving and reentering the site.

    Reply
    • Rich Stillman
      Rich Stillman says:

      Barbara, thanks for bringing this to our attention. We have fixed this issue so you shouldn’t have any more problems.

      Reply
  3. StormysAunt
    StormysAunt says:

    Hi, I just submitted a listing and one of the pictures got turned on its side. I am trying to edit the listing, and can’t seem to get back to the page where I can do the edit. I wonder how I might get there?

    Thank you! Julene

    Reply
    • Rich Stillman
      Rich Stillman says:

      Hi Julene,

      Thanks for writing. Did you upload images taken with your smartphone camera? I believe that issue is caused by which way you shot them, landscape or portrait. You’re not the only one that has had that issue. We believe we have found a fix for that. Yours are looking correct now.

      Thanks for listing with us. Let us know if we can help further.

      Reply

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *